首页 > 编程知识 正文

hduoj Treasure the new start freshmen

时间:2023-05-04 13:25:08 阅读:255591 作者:3760

Treasure the new start, freshmen!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22013    Accepted Submission(s): 6522

Problem Description

background:
A new semester comes , and the HDU also meets its 50th birthday. No matter what's your major, the only thing I want to tell you is:"Treasure the college life and seize the time." Most people thought that the college life should be colorful, less presure.But in actual, the college life is also busy and rough. If you want to master the knowledge learned from the book, a great deal of leisure time should be spend on individual study and practise, especially on the latter one. I think the every one of you should take the learning attitude just as you have in senior school.
"No pain, No Gain", HDU also has scholarship, who can win it? That's mainly rely on the GPA(grade-point average) of the student had got. Now, I gonna tell you the rule, and your task is to program to caculate the GPA.
If there are K(K > 0) courses, the i-th course has the credit Ci, your score Si, then the result GPA is If there is a 0 <= Si < 60, The GPA is always not existed.

Input

The first number N indicate that there are N test cases(N <= 50). In each case, there is a number K (the total courses number), then K lines followed, each line would obey the format: Course-Name (Length <= 30) , Credits(<= 10), Score(<= 100).
Notice: There is no blank in the Course Name. All the Inputs are legal

Output

Output the GPA of each case as discribed above, if the GPA is not existed, ouput:"Sorry!", else just output the GPA value which is rounded to the 2 digits after the decimal point. There is a blank line between two test cases. 

Sample Input

 

2 3 Algorithm 3 97 DataStruct 3 90 softwareProject 4 85 2 Database 4 59 English 4 81

Sample Output

 

90.10 Sorry!

Author

zl

#include<stdio.h>
#include<string.h>

int main()
{
    int n;
    
    char a[31];
    double b;
    double c;
    scanf("%d",&n);
    //getchar();
    while(n--)
    {
        
        int f=0,i,j,k;
        double  sum1=0,sum2=0;
        scanf("%d",&k);
        for(i=0;i<k;i++)
        {
            scanf("%s %lf %lf",a,&b,&c);
            sum1+=b*c;
            sum2+=b;
            if(c<60)
            f=1;
        }
        if(f!=1)
        printf("%.2lfn",(double)1.0*sum1/sum2);
        else
        printf("Sorry!n");
        if(n)
        printf("n");
    }
    return 0;
}

不要用结构体,太麻烦,而且提交上去运行出错。

版权声明:该文观点仅代表作者本人。处理文章:请发送邮件至 三1五14八八95#扣扣.com 举报,一经查实,本站将立刻删除。